๐Ÿ‘‰ Jika Anda Memasang Plugin Tidak Diuji Dengan Versi WordPress Anda?

Bagaimana untuk membuat Blog WordPress

Sering kali pengguna kami meminta kami tentang amaran bahawa plugin tidak diuji dengan versi WordPress mereka. Sekiranya anda memasang plugin yang plugin? atau cari plugin lain? Dalam artikel ini, kita akan membincangkan mengapa anda perlu memasang plugin yang tidak diuji dengan versi WordPress anda? Apakah maksudnya dan bagaimana anda boleh membantu komuniti WordPress?

Apabila anda memasang plugin dari kawasan admin WordPress, anda mungkin melihat amaran bahawa plugin tidak diuji dengan versi WordPress anda.

Bagaimana WordPress Tidak Dapat Menguji Maklumat?

Repositori plugin rasmi WordPress adalah koleksi terbesar plugin WordPress sumber bebas dan terbuka. Apabila menyerahkan pemalam, penulis dikehendaki menghantar fail "readme" dengan pemalam mereka. Fail readme ini kemudiannya digunakan oleh direktori plugin untuk menjana halaman plugin.

Fail readme mengandungi "Diuji sehingga" tag yang digunakan untuk memaparkan maklumat. Pengarang Plugin dijangka menyimpan maklumat ini sehingga kini.

Ini bermakna bahawa dengan setiap pembebasan WordPress, penulis plugin harus menguji pemalam mereka dan mengemas kini fail readme untuk pemalam mereka.

Mengapa Penulis Tidak Update Plugin Maklumat Ini?

Banyak penulis plugin tidak mengemas kini fail readme mereka walaupun mereka menguji plugin mereka dengan versi terkini.

Di dunia yang ideal, kami ingin semua pengarang plugin mengemas kini maklumat ini. Tetapi kita tidak hidup dalam dunia yang ideal.

Ingat bahawa plugin ini bebas, dan anda tidak membayar penulis untuk memuat turun dan menggunakannya. Pengarang plugin merasa kurang cenderung untuk mengemas kini fail readme dengan setiap pembebasan. Mereka biasanya sibuk dengan pekerjaan sepenuh masa dan projek pembangunan berbayar.

Tutorial Video

Langgan WPBeginner

Sekiranya anda tidak menyukai video atau memerlukan lebih banyak arahan, teruskan membaca.

Sekiranya saya Memasang Plugin ini?

Ya, anda patut. Hanya kerana pengarang plugin tidak mengemas kini fail readme mereka tidak bermakna bahawa mereka tidak menguji plugin mereka atau bahawa plugin tidak berfungsi dengan versi terkini WordPress.

Jika anda mendengar tentang plugin di WPBeginner, maka anda dengan selamat boleh menganggap bahawa kami menguji plugin dengan versi terkini WordPress. Sekiranya artikel itu, anda lihat diterbitkan agak baru-baru ini, maka ini bermakna bahawa plugin itu serasi dengan versi WordPress terkini.

Sebaliknya, jika plugin belum dikemas kini selama lebih daripada dua tahun, maka ini bermakna kemungkinan plugin tersebut telah ditinggalkan. Dalam kes itu, anda tidak perlu memasang pemalam.

Akan menarik perhatian bahawa banyak plugin yang belum dikemas kini selama lebih dari dua tahun sebenarnya masih berfungsi dengan baik. Walau bagaimanapun, anda perlu memasangnya dengan risiko anda sendiri.

Bagaimana Anda Boleh Bantu?

Anda boleh memasang plugin di laman WordPress anda dan mengujinya. Jika ia berfungsi seperti yang diharapkan, kemudian kembali ke halaman plugin. Log masuk dengan nama pengguna dan kata laluan WordPress.org anda. Seterusnya, tatal ke bahagian bawah halaman di mana anda akan melihat bahagian keserasian.

Hanya pilih versi WordPress anda, versi plugin, dan kemudian klik pada butang Kerja. Dengan melakukan itu, anda membiarkan pengguna lain mengetahui bahawa anda telah menguji plugin, dan ia berfungsi seperti yang dijanjikan.

Anda juga boleh menghubungi pengarang plugin dan sila minta mereka mengemas kini fail readme plugin mereka

Apa yang perlu dilakukan Apabila Plugin rosak?

Sekali lagi, kami ingin mengingatkan pengguna bahawa jika ia adalah plugin percuma, maka penulis plugin telah menyediakannya secara as-base. Tidak ada waranti, bahkan jaminan waranti tersirat. Tetapi persoalannya, bagaimana anda boleh membantu komuniti menangani plugin yang patah?

Daripada meninggalkan komen yang keras pada thread sokongan plugin, anda boleh meninggalkan maklum balas yang membina dan membantu. Lihat panduan kami tentang bagaimana untuk meminta sokongan WordPress dengan betul dan mendapatkannya.

Sebelum melakukan apa-apa, cuba pasang pemalam pada memasang WordPress langsung atau tempatan yang berbeza. Pastikan anda dapat menghasilkan semula kesilapan yang sama pada pemasangan lain juga.

Sebaik sahaja anda yakin bahawa pemecah rusak, hanya huraikan ralat dalam benang sokongan dan biarkan ia untuk penulis plugin atau komuniti untuk bertindak balas. Jika anda tidak mendapat respons, maka anda boleh cuba menghubungi pengarang plugin. Kebanyakan pengarang plugin mempunyai maklumat hubungan di halaman profil WordPress.org mereka.

Jika langkah-langkah ini gagal, maka anda harus berasa bebas untuk melawat halaman pemalam dan mengundi plugin yang patah di bawah bahagian keserasian.

Kami berharap artikel ini membantu menjawab soalan anda sama ada anda perlu memasang plugin yang tidak diuji dengan versi WordPress anda.

Sekiranya anda menyukai artikel ini, sila melanggan tutorial video YouTube kami untuk tutorial video WordPress. Anda juga boleh mencari kami di Twitter dan Google+.

Tonton video itu: Cara Membuat Blog atau Laman Web di

Like this post? Please share to your friends:
Tinggalkan Balasan

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: